Kan inte hämta från...
 
Notifications
Clear all

Kan inte hämta från Viafree


Mayor.doof
(@mayor-doof)
Nykomling VIP
Blev medlem: 3 år sedan
Inlägg: 6
Topic starter  

Hej.

Har suttit några dagar med ett problem men känner att jag kommit till vägs ände. Får ingen ordning på nerladdning ifrån Viafree.

Provar att hämta med svtplay-dl och även med uman-downloader. Skapat en yaml-fil i %appdata%\svtplay.dl men får enbart "No videos found. You need to login". Naturligtvis gör jag något fel, men vad?

För att enklare se vad som händer kör jag Python svtplay.dl --config c:\users\user\appdata\roaming\svtplay-dl\svtplay-dl.yaml samt adressen till det jag vill hämta. I yaml-filen har jag lagt in det som föreslagits på andra ställen i forumet och naturligtvis även min inloggning på Viafree.

Samma sak om jag använder vanliga uman downloader. Precis som om den inte läser yaml-filen eller om det är fel i den. Har kontrollerat ett flertal gånger men hittar inget fel eller skillnad.

Har även provat söka runt via google osv efter hjälp men hittar inget som jag gör fel eller annorlunda.

Hoppas på hjälp.

Kör en Windows 10 och har använt svtplay-dl och youtube-dl under en längre tid utan större problem. Vill inte betrakta mig som en nybörjare men nu känner jag mig helt blank på ideer. 


Citera
uman231
(@uman231)
Support & Programmerare Admin
Blev medlem: 5 år sedan
Inlägg: 1785
 
Postad av: @mayor-doof

Hej.

Har suttit några dagar med ett problem men känner att jag kommit till vägs ände. Får ingen ordning på nerladdning ifrån Viafree.

Provar att hämta med svtplay-dl och även med uman-downloader. Skapat en yaml-fil i %appdata%\svtplay.dl men får enbart "No videos found. You need to login". Naturligtvis gör jag något fel, men vad?

För att enklare se vad som händer kör jag Python svtplay.dl --config c:\users\user\appdata\roaming\svtplay-dl\svtplay-dl.yaml samt adressen till det jag vill hämta. I yaml-filen har jag lagt in det som föreslagits på andra ställen i forumet och naturligtvis även min inloggning på Viafree.

Samma sak om jag använder vanliga uman downloader. Precis som om den inte läser yaml-filen eller om det är fel i den. Har kontrollerat ett flertal gånger men hittar inget fel eller skillnad.

Har även provat söka runt via google osv efter hjälp men hittar inget som jag gör fel eller annorlunda.

Hoppas på hjälp.

Kör en Windows 10 och har använt svtplay-dl och youtube-dl under en längre tid utan större problem. Vill inte betrakta mig som en nybörjare men nu känner jag mig helt blank på ideer. 

Utan att ha sett din fil gissar jag på en indent problematik finns i den..

 


SvaraCitera
Mayor.doof
(@mayor-doof)
Nykomling VIP
Blev medlem: 3 år sedan
Inlägg: 6
Topic starter  

Min yaml-fil

 

service:
  viafree:
    username: [email protected]
    password: MittLösenPåViafree

 

Har gjort en klipp och klistra ifrån forumet.

Och Ja den heter .yaml och inte .txt eller annat.


SvaraCitera
uman231
(@uman231)
Support & Programmerare Admin
Blev medlem: 5 år sedan
Inlägg: 1785
 

@mayor-doof 

Byt till denna och editera den bara i username och password..
Kan va encoding eller liknande som är fel för dig med...


SvaraCitera
Mayor.doof
(@mayor-doof)
Nykomling VIP
Blev medlem: 3 år sedan
Inlägg: 6
Topic starter  

Tyvärr samma fel både med downloader och Python.

 


SvaraCitera
uman231
(@uman231)
Support & Programmerare Admin
Blev medlem: 5 år sedan
Inlägg: 1785
 

@mayor-doof 

testa lägga "" runt user och pass

Kan vara något tecken i tex lösen som stör...

service:
  viafree:
    username: "[email protected]"
    password: "MittLösenPåViafree"

SvaraCitera
Mayor.doof
(@mayor-doof)
Nykomling VIP
Blev medlem: 3 år sedan
Inlägg: 6
Topic starter  

Du har förmodligen löst problemet.

Jag satt inte "" runt texten. Däremot bytte jag till ett kortare lösenord. Och då fungerade det.

Tydligen hade jag för långt lösenord.

Stort tack för hjälpen. Suttit ett antal timmar och sedan löser du det på 30 minuter. Grymt!!


SvaraCitera
Martin24
(@martin24)
Medlem Moderator
Blev medlem: 4 år sedan
Inlägg: 641
 

@mayor-doof Jag ser direkt vad felet är, du har skrivit fel på:

.

och

-

Du har skrivit i din post:

%appdata%\svtplay.dl

Det korrekta är:

%appdata%\svtplay-dl

Sen har du skrivit:

svtplay.dl --config c:\users\user\appdata\roaming\svtplay-dl\svtplay-dl.yaml 

Det korrekta är:

svtplay-dl --config c:\users\user\appdata\roaming\svtplay-dl\svtplay-dl.yaml 

SvaraCitera
Martin24
(@martin24)
Medlem Moderator
Blev medlem: 4 år sedan
Inlägg: 641
 

@uman231 Jag har inga citattecken i min fil men jag gissar att det funkar på samma sätt som när man till exempel skriver in en sökväg i "Kör" i Windows, alltså att citattecken bara behövs om sökvägen innehåller blanksteg?

Fast det är väl väldigt få tjänster som godkänner att man har blanksteg i lösenord? Jag vet att Google tillåter det men vet inte om Viafree och/eller Cmore tillåter det.

Sen brukar det aldrig vara bra att använda å,ä,ö i lösenord, det kan skapa problem i vissa sammanhang så det ska man helst undvika.


SvaraCitera
uman231
(@uman231)
Support & Programmerare Admin
Blev medlem: 5 år sedan
Inlägg: 1785
 

@martin24 

Det finns många tecken som kan ställa till saker i filer likt detta \ är sällan lyckat samma sak med = och + kan ibland ge problem


Martin24 gillade
SvaraCitera
Share:
Creeper